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QGIS EDIARI

s - e - “ =~ QGIS is a free and open-source desktop geographic
e v = information system (GIS) . It allows to create, edit,
visualize, analyze and publish geospatial information on

QGIS T il st sl eeaae 20230623 120000 UTC 3428 6m Windows, macOS, Linux, BSD.

A Free and Open Source Geographic Information System

Most recent release is v. 3.30 (Hertogenbosch)

Most recent long term release is v. 3.28 (Firenze)
Maintained by volunteers developers

Has a lot of plugins (1800+): https://plugins.qgis.org/
Website: https://www.qgis.org/en/site/

@GIS 3.30 's-Hertogenbosc@

hds been released!

New release: 3.30!

Get the for your Operating System and read the



https://plugins.qgis.org/
https://www.qgis.org/en/site/

QGIS overview of the interface

Project Edit View Layer Settings Plugins Vector Raster Database Web Mesh Progessing Help
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QGIS Add a basemap

Browser
BN g )
B8 Vector Tiles
v IiE XYZ Tiles
i2% Mapzen Global Terrain
222 OpenStreetMap
» & Wes
» &) WFS / OGC API - Features
~ &) ArcGIS REST Servers
» = Arpae suolocolture
* GeoNode

* Inthe Browser panel, scroll down to find
XYZ Tiles

]
Layers

DA R SRR B
v |V = OpenStreetMap

* Click the down arrow to reveal
OpenStreetMap

* Click and drag OpenStreetMap down to
the bottom Layers list




Web Mapping Services

A Web Mapping Service (WMS) is a service hosted on a
remote server. Similar to a website, you can access it as
long as you have a connection to the server. Using QGIS,
you can load a WMS directly into your existing map.

To add WMS layers:

+ click on the Open the Data Source Manager tool ﬂ
and enable the WMS/WMTS tab

+ or from the menu Layer > Add Layer > Add
WMS/WMTS Layers

 create a new connection giving a name and a URL

@ Crea una Nuova WMS/WMTS Connessione X

Dettagli Connessione

Nome |Ferrara ortofota| ‘

URL |https:stt.comune.fe.it!geoserverswt{Ferrara{wms ‘
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WMS examples

 Emilia-Romagna Region Orthophoto AGEA 2020:
https://servizigis.regione.emilia-
romagna.it/wms/agea2020_rgb?request=GetCapabilitie
s&service=WMS

+ Ferrara Orthophoto 2022 urban area:
https://sit.comune.fe.it/geoserversit/Ferrara/Ortofoto20
22/wms?service=WMS&version=1.3.0&request=GetCap
abilities

* Ferrara buildings urban area:
https://sit.comune.fe.it/geoserverckan/Ferrara/Fabbrica
1i_USAGE_preview/wms?service=WMS&version=1.3.0&r
equest=GetCapabilities

 carta storica AiPO:
http://geomap.reteunitaria.piemonte.it/ws/siti/aipo-
01/sitiwms/wms_aipo_cartografiastorica?service=WMS
&version=1.3.0&request=GetCapabilities



https://servizigis.regione.emilia-romagna.it/wms/agea2020_rgb?request=GetCapabilities&service=WMS
https://sit.comune.fe.it/geoserversit/Ferrara/Ortofoto2022/wms?service=WMS&version=1.3.0&request=GetCapabilities
https://sit.comune.fe.it/geoserverckan/Ferrara/Fabbricati_USAGE_preview/wms?service=WMS&version=1.3.0&request=GetCapabilities
http://geomap.reteunitaria.piemonte.it/ws/siti/aipo-01/sitiwms/wms_aipo_cartografiastorica?service=WMS&version=1.3.0&request=GetCapabilities

Web Feature Services

The Open Geospatial Consortium Web Feature Service
(WFS) provides an interface allowing requests for
geographical features across the web

Whereas the WMS returns an image, the WFS returns a
Geography Markup Language (GML), an XML dialect
which can be used to model geographic features.

https://labora.dedagroup.it/geoserver/EDIAQI-
Ferrara/ows?request=GetCapabilities&service=WFS



https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/ows?request=GetCapabilities&service=WFS

WFS connect from Excel

Form excel :

Go to Data > Get External Data > From Web

In the address bar, write the web address of a WFS with parameter

outputformat=csv

Press the Load button.
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https://sit.comune.fe.it/geoserverckan/Ferrara/Ciclabili_2021_preview/wfs?service=WFS&version=1.3.0&re

quest=GetFeature&typename=Ferrara:Ciclabili_2021_preview&outputformat=csv

FID
Ciclabili_2021_preview.48
Ciclabili_2021_preview.367
Ciclabili_2021_preview.916
Ciclabili_2021_preview.919
Ciclabili_2021_preview.951

Ciclabili_2021_preview.1010
Ciclabili_2021_preview.1048

Ciclabili_2021_preview.828
Ciclabili_2021_preview.12

Ciclabili_2021_preview.51

Ciclabili_2021_preview.110
Ciclabili_2021_preview.641
Ciclabili_2021_preview.939
Ciclabili_2021_preview.457
Ciclabili_2021_preview.533
Ciclabili_2021_preview.340

48
367
916
919
951

1010
1048

828
12
51

110

641

939

457

533

340

~|gid| ~ |id | ~ |note_geom -  layer

394
884
1076
1347
330
68
414
1027
278
532

percorsi esistenti
percorsi esistenti
percorsi esistenti
percorsi esistenti
percorsi esistenti
percorsi esistenti
percorsi esistenti
percorsi esistenti
percorsi di progetto pums
percorsi di progetto pums

552 [interrotto e pipercorsi di progetto pums
72 [interrotto ed (percorsi esistenti
976 [interrotto ed (percorsi esistenti

848
856
487

percorsi esistenti
percorsi esistenti
percorsi di progetto pums

- |segnaletic

no

no

solo verticale

no

verticale e orizzontale
solo verticale

solo verticale

solo verticale

solo verticale
no
no
no

~ |note_segna

limite 30 + dosso


https://sit.comune.fe.it/geoserverckan/Ferrara/Ciclabili_2021_preview/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=Ferrara:Ciclabili_2021_preview&outputformat=csv
https://sit.comune.fe.it/geoserverckan/Ferrara/Ciclabili_2021_preview/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=Ferrara:Ciclabili_2021_preview&outputformat=csv
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WFS Filtering and the Common Query Language (CQL) EDIAR

CQL (Common Query Language) is a query language created by the OGC. Unlike the XML-based Filter Encoding language,
CQL is written using a familiar text-based syntax. It is thus more readable and better-suited for manual authoring.

In the WFS request add the parameter cql_filter: &cql_filter=layer="percorsi esistenti’

« no filter (and output format json):
https://sit.comune.fe.it/geoserverckan/Ferrara/Ciclabili_2021_preview/wfs?service=WFS&version=1.3.0&request=Get
Feature&typename=Ferrara:Ciclabili_2021_preview&outputFormat=application/json

* totalFeatures 1051

« with filter (and output format json)
https://sit.comune.fe.it/geoserverckan/Ferrara/Ciclabili_2021_preview/wfs?service=WFS&version=1.3.0&request=Get
Feature&typename=Ferrara:Ciclabili_2021_preview&outputFormat=application/json&cal_filter=layer=%27percorsi%20e
sistenti%27

» totalFeatures 861



https://sit.comune.fe.it/geoserverckan/Ferrara/Ciclabili_2021_preview/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=Ferrara:Ciclabili_2021_preview&outputFormat=application/json
https://sit.comune.fe.it/geoserverckan/Ferrara/Ciclabili_2021_preview/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=Ferrara:Ciclabili_2021_preview&outputFormat=application/json&cql_filter=layer=%27percorsi%20esistenti%27

EDIAQI PilotBuildingsFerrara

Layer preview:

http://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wms?service=WMS&version=1.1.0&request=GetMap&layers=EDIAQI-
Ferrara:PilotBuildingsFerrara&bbox=704366.66443,4967078.67264,709941.13115,4970086.804978&width=768&height=414&srs=EPSG:7791&styles=&format=application/openl
ayers

WMS GetCapabilities (to add layer to QGIS o from browser):
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/ows?request=GetCapabilities&service=WMS

WFS GetCapabilities (to add layer to QGIS o from browser):
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/ows?request=GetCapabilities&service=WFS

WFS GetFeature:

°  output format CSV to connect from Excel/Google Sheets (&outputformat=csv)
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=EDIAQI-
Ferrara:PilotBuildingsFerrara&outputformat=csv

° output format json (&outputFormat=application/json)
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=EDIAQI-
Ferrara:PilotBuildingsFerrara&outputFormat=application/json

° output format shapefile (&outputformat=shape-zip)
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=EDIAQI-
Ferrara:PilotBuildingsFerrara&outputformat=shape-zip

¢ filter (&cq_filter=Type='School’)
° https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=EDIAQI-
Ferrara:PilotBuildingsFerrara&outputFormat=application/json&cqgl_filter=Type=%27School%27



http://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wms?service=WMS&version=1.1.0&request=GetMap&layers=EDIAQI-Ferrara:PilotBuildingsFerrara&bbox=704366.66443,4967078.67264,709941.13115,4970086.80497&width=768&height=414&srs=EPSG:7791&styles=&format=application/openlayers
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/ows?request=GetCapabilities&service=WMS
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/ows?request=GetCapabilities&service=WFS
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=EDIAQI-Ferrara:PilotBuildingsFerrara&outputformat=csv
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=EDIAQI-Ferrara:PilotBuildingsFerrara&outputFormat=application/json
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=EDIAQI-Ferrara:PilotBuildingsFerrara&outputformat=shape-zip
https://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/wfs?service=WFS&version=1.3.0&request=GetFeature&typename=EDIAQI-Ferrara:PilotBuildingsFerrara&outputFormat=application/json&cql_filter=Type=%27School%27
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Progetto Modifica Visualizza Layer Impostazioni Plugins Vettore Raster Web Mesh Processing Guida SensorThings API
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https://servizigis.regione.emilia-romagna.it/wms/agea2020_rgb?request=GetCapabilities&service=WMS
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https://sit.comune.fe.it/geoserverckan/Ferrara/Fabbricati_USAGE_preview/wms?service=WMS&version=1.3.0&request=GetCapabilities
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JSON  Dati non elaborati

8 labora.dedagroup.it/geoserver/EDIAQI-Ferrara/ows?service =WFS&uversion=1.0.0&request=GetFeaturedttypeName=FE ﬂ?

Header

Salva Copia Comprimitutto Espandi tutto % Filtra JSON

type:
v features:
v 0:
type:
id:
w geometry:
type:
w coordinates:
w 9
b O:
geometry_name:

w properties:

Address:
Type:
v 1:
type:
id:
w geometry:

type:

w coordinates:
v 9:

v 0:

- 0:

v 1:

"FeatureCollection”

"Feature”

"PilotBuildingsFerrara.1"

"MultiPolygon"

[-]

“geom”

"Municipality Ferrara - Environment Department”

"Via Marconi 39"

"Office (public)”

"Feature"

"PilotBuildingsFerrara.2"

"MultiPolygon™

704389.90217083
A968341.79478874

v features:
v a:
type:
id:
v geometry:

type:

v 0:
v o

v 0:

v 2:

v 3:

"Feature”

"PilotBuildingsFerrara.1"

"MultiPolygon™

705424.67999231
4969740 . 21658866

705423.29979029
4969739 .72245394

705422.23063239
4969739.82327527

705421.97506669
4969739.39231331

705421.56711231
4969736.0201553

http://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/ows?service=WFES&version=1.0.0&request=GetFeature&typeName=EDIAQI-

Ferrara%3APilotBuildingsFerrara&maxFeatures=50&outputFormat=application%2Fjson



http://labora.dedagroup.it/geoserver/EDIAQI-Ferrara/ows?service=WFS&version=1.0.0&request=GetFeature&typeName=EDIAQI-Ferrara%3APilotBuildingsFerrara&maxFeatures=50&outputFormat=application%2Fjson
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GeoNext + AQ stations + http://geomap.reteunitaria.piemonte.it/ws/siti/aipo-01/sitiwms/wms_aipo_cartografiastorica?service=WMS&request=getCapabilities



http://geomap.reteunitaria.piemonte.it/ws/siti/aipo-01/sitiwms/wms_aipo_cartografiastorica?service=WMS&request=getCapabilities

